Springe zum Inhalt

igmproxy: Telekom IPTV mit EdgeRouter

Da auch mein Anschluß nun von der Telekom-Zielnetzarchitektur auf BNG umgestellt wurde, trat auch hier das Problem zutage, dass igmproxy im EdgeRouter angeblich nicht mit VLAN-getaggten Schnittstellen umgehen kann. Doch es gibt eine Lösung, welche ich in einem Forenbeitrag unten beschrieben habe, da ich denke, dass auch hier wieder erhöhter Diskussionsbedarf wie in meinem älteren Beitrag zu IPTV mit dem EdgeRouter entsteht.

Update (hier der Inhalt aus dem ehemaligen Forum):

Ich habe gute Nachrichten für alle, die von obigem Fehler bei Telekom-IPTV mit dem EdgeRouter geplagt sind. Die Fehlermeldung wird von igmproxy (welcher zum Routen der Multicast-Pakete und Verarbeiten von IGMP erforderlich ist) verursacht und findet sich in /var/log/messages des EdgeRouters.

Lt. dem Ubiquity-Forum unterstützt igmproxy in der aktuellen Version keine VLAN-Interfaces, wie sie für die Internetanschlüsse der Telekom erforderlich sind. Das ist falsch. Vielmehr unterstützt igmproxy keine Interfaces, welchen keine IP-Adresse zugewiesen wurde. Es lässt sich sehr wohl so konfigurieren, dass auch der EdgeRouter korrekt mit Telekom-IPTV zusammenarbeitet.

Für die (alte) Zielnetzarchitektur:

  • eth1.8, VLAN 8 holt eine IP-Adresse per DHCP von der Telekom (meist 10.*.*.*)
  • als Upstream-Interface kann dann eth1.8 beim igmproxy eingestellt werden

Für Kunden, die schon auf BNG umgestellt sind:
Alles läuft nur noch über VLAN 7. Jedoch erhält das Interface eth1.7 keine IP-Adresse, sondern erst das "hintendran" hängende pppoe0.

  • pppoe0 als Upstream-Interface in igmproxy einstellen

Folgende Firewall-Regeln müssen noch für das jeweilige Interface festgelegt werden:

Anschließend funktioniert IPTV sofort.