Sofern man HHVM aus dem entsprechenden Wheezy-Repositiory installiert hat, kann HHVM aktuell nicht auf Version 3.4.1 aktualisiert werden. Vom Paket vorausgesetzt wird die Version 4.9 von libstdc++6, in Wheezy ist jedoch nur Version 4.8 vorhanden.

Der Paketmaintainer arbeitet an einer Lösung und hat diese für das Jahresende angekündigt.

Update vom 22.12.2014: Das Problem ist offensichtlich mit Version 3.4.2 von HHVM behoben.